
Code and
Contact
Manange-
ment

Springbrook Software

www.springbrooksoftware.com

http://help.madcapsoftware.com/


Table of Contents
CM Module Overview 3
Create an Issue 6
Issue Search 19
Issue Step Search 21
Comment Code Maintenance 23
Form Maintenance 25
Create an Issue Status 28
Issue Type Maintenance 30
Create a QBE Report in CM 41
Queue Maintenance 50
Resolution Type Maintenance 53
Web Approvals Maintenance 55
Web Source Maintenance 56
Issue Detail Report 58
Print an Issue 62
Set up the CM Module 68
Approve Web Submissions 72

TABLE OF CONTENTS 2



CM> Overview

CMModule Overview

The Code and Contact Management module is used to track all citizen correspondence

and can be is used to create, track, and report on issues related to lots and customer

accounts. The information stored on an issue is fairly flexible so the module can be used for

a variety of events or incidents. The module can be used for tracking code enforcement

issues such as overgrown vegetation, vehicles parked on lawns, or improperly contained

refuse. The module can also be used to track requests for services such as street repairs

or utility billing service requests.

Creating an Issue

The creation and processing of issues and issue steps will generally take place in the Issue

Search window (CM> Issues> Issues Search).

In order to create a Code and Contact Management issue, you must first set up the issue

types, which act as templates when creating issues. When an issue type is attached to an

issue, it will populate the fields of the issue with the default values set up on the issue type.

Issue types reduce data entry and data error and allow similar issues to be processed in a

uniform way. You should set up an issue type for each recurring issue to ensure that the

issues will be processed in the same way and with consistent information.
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You will also need to establish Issue Queues. Queues are used to assign issue respons-

ibilities to departments or individual Springbrook users.

Creating Issue Steps

Issues can be processed and completed in a single step or in multiple steps. This allows

you to assign portions of the process to certain queues or specific Springbrook users.

Issues inherit the issue steps from the attached issue type, but you can modify the issue

steps on each issue as the issue is processed and the issue steps are completed.

Issue steps can also be used to perform a specific action. The actions that can be per-

formed by an issue step are the creation of an Accounts Receivable invoice or a Utility

Billing module service request. These actions will be performed on the customer or lot

attached to the issue.

Each issue step will contain a completion date and time that can be used in reporting. Each

issue step also has a scheduled date and time of completion field, which allows you to

schedule, plan, and monitor the issue workflow.

Attaching Forms to Issues

Issue steps can also contain forms, which can be sent to the customer attached to the

issue as the step is processed. These forms are Microsoft Word documents that can con-

tain merge fields from the issue record.
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Resolving Issues

Once the steps of an issue are complete, the issue is resolved and a user-defined res-

olution code is attached to the issue. The resolution code can be used to filter issues in

reporting.

Information Tracking

There are several user-defined fields on every issue that allows you to customize the

information tracked on each issue. The values in these miscellaneous fields will display on

the printed version of the issue and can be used in reporting with the QBE reporting tool in

the Code and Contact Management module.
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CM> Issues> Issues Search

Create an Issue

Summary

Follow this process to open, edit, or create an issue in the Code and Contact Management

module.

Step by Step

1     Open the Issue Search window (CM> Issues> Issue Search).

2     Create an issue from an issue type and complete the General tab. 

l Click the Create icon to create a new issue. This will open the Issue Main-

tenance window.

l Select an Issue Type or click the field label to select one from a list.

l Issue types can be activated by un-checking the Inactive toggle on the Issue

Type Maintenance window (CM> Maintenance> Issue Type> General tab).
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l Once you have selected an issue type, the other sections on the General tab will be

populated and enabled.

l The Type Description field will populate with the description specified on the Issue

Type Maintenance window. This field cannot be edited.

l The Issue Number field will populate with the next available unique issue number.

The Issue Number functions as the index for issues, just like the Customer Number

acts as an index for customers. You will not be able to modify the value in this field.

l Enter a unique Citation Number for the Issue. This field can function as an addi-

tional index if you set up this field to be unique.

l You can force the window to require a unique citation number by checking the

Enforce Unique Citation Numbers toggle during the CM Setup process

(CM> Utilities> Setup).

l The Issue Detail Listing report and printed Issues can be filtered by the Cit-

ation Number field. You can also locate issues by the Citation Number with

the Issue Search window.

l The Citation Number field will display on the description of an AR invoice if

you have checked the Use Citation Number in Invoice Description toggle

during the CM Setup process (CM> Utilities> Setup).

l The Issue Status field will populate with the status specified for the selected Issue

Type. You can edit this field by clicking the field label to select a new issue status.

l Statuses are user-defined codes set up on the Status Maintenance window

(CM> Maintenance> Issue Status).

l The Issue Date field will default to the current date but can be modified when the

issue is created. After the issue has been saved, you will not be able to modify the

issue date.
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l TheWeb User field will populate with the web user's username if the issue was gen-

erated through the Online Code and Contact Management application.

l The Issue Description field will populate with the issue type description specified

on the Issue Type Maintenance window (CM> Maintenance> Issue Type> Issue sec-

tion> Description field).

l The Ordinance field is a large text field that can be used to enter the ordinance num-

ber of an issue. This field is not required but will display on the printed version of the

issue.

l The Notes field can be used for general notes and will display on the printed version

of the issue.

l The Source fields are used to enter information on the person creating the issue.

Use these fields to attach the customer that initiated contact to the issue. This is an

optional section.

l Enter a Source Customer Number or click the field label and select a cus-

tomer number to add a source customer to the issue.

l The Source Customer Number can be added to forms and will display on the

Print Issue report (CM> Reports> Print Issue).

l Enter a Source Description. The issue Source Description will display in the

printed version of the issue. This field can be up to 1000 characters long.

l The Target fields are used to enter information on the person or lot the issue con-

cerns. Select either a lot or a customer account.

l Click the Target Customer Number field label to select a customer from a

list. If you would like to add both a lot and a customer to an issue, click the Lot

Number field label first and select a lot from the list. The customer account

attached to the lot will populate in the Target Customer Number field, along
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with the Business Phone, Home Phone and Street Address fields.

l If a step in the issue is creating an AR Invoice and you select a cus-

tomer with only a Utility Billing account, an AR account will be created

for that customer when the AR Invoice is generated.

l If the issue is going to create a Utility Billing service request you must

attach a lot with an active utility billing customer account.

l If you are creating an issue that does not perform an action or only cre-

ates a service request, you do not have to select a customer.

l If a customer number has already been selected in the Target Customer

Number field, selecting a Lot Number will not affect the selected cus-

tomer record. You will, however, be required to confirm the lot selection.

l Enter a Target Description if desired. This field will display on the prin-
ted version of the issue.

l The Resolution fields should only be completed after the issue has been resolved.

l Select a Resolution Type from the drop-down menu when the issue is com-

plete or resolved.

l If you select a resolution before the issue steps are complete and save the

issue, you will be prompted to confirm your choice. All the open issue steps

will be marked as complete, but the issue step actions will not be performed.

l Once you select a resolution from the drop-down menu, the Resolution

Notes field below the Resolution Type field will be enabled.

l The Resolution fields will display on the printed version of the issue.

l Resolutions are created and maintained on the Resolution Maintenance win-

dow (CM> Maintenance> Resolution Type).
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3     Complete the Steps tab. 

l The Steps of the issue will populate from the steps set up on the issue type selected

on the General tab in the Issue Type field. You can add, delete, or modify the steps

of the issue if needed. Changes made to the issue will only affect the issue, not the

issue type attached to the issue.

l Incomplete steps will display in red.

l Click the Create icon drop-down menu and select New Step to add a new step

to the issue type.

l You can have up to 15 steps on an issue and still be able to print all of the

steps on a form.

l The Queue, User and Role fields are used to associate Springbrook users with the

issue step. These fields serve two purposes.

l When a queue and a user are associated with the issue step, you can use the

Issue Step Search window to display, sort and export the issue step details

associated with the queue or user.

l When a queue, user or role is associated with the issue step, the issue step

can be set up to notify the Springbrook users attached to the specified queue,

user or role when the prior issue step has been completed and the current

issue step requires their attention.

l The issue step is set up to notify the queue, user or role in the Noti-

fication Recipient drop-down menu below. Only the user type selected

in this field will be notified. For example, if an issue step is associated

with a queue, user and role, and User is specified as the notification

type in the field below, only the user will receive the notification. This
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also means that if the issue step is associated with a queue and a role

but not associated with a user, no notification would be generated.

l The type of notification generated is determined by the user's User

Preferences settings (User Preferences icon > General tab> Alert

Method drop-down menu).

l Select a Queue from the drop-down menu to associate a queue with the issue

step.

l If the Enable queue restrictions toggle is checked on the CM Setup

window, this field will only be accessible to the queue member set up as

Administrator.

l If the issue step is set up to notify by queue, all the members of the

selected queue will receive a notification when the issue step requires

attention.

l Queues are created and maintained on the Queue Maintenance win-

dow (CM> Maintenance> Queues).

l Select a User from the drop-down menu to associate a user with the issue

step.

l Only Springbrook users that are attached to the queue selected above

will display in the drop-down menu.

l If the issue step is set up to notify by user, the selected user will receive

a notification when the issue step requires attention.

l Users are created and maintained on the User Maintenance window

(SS> Security> User).
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l Click the Role field label to associate a role with the issue step.

l If the issue step is set up to notify by role, all the Springbrook users

associated with the selected role will receive a notification when the

issue step requires attention.

l For user-based roles, the Springbrook user specified on the role

will be notified.

l For position-based roles, any Springbrook user whose PR

Employee record is associated with the specified position will be

notified.

l Roles are created and maintained on the Role Maintenance window

(SS> Security> Role).

l The Notification Recipient drop-down menu is used to

l Select an Action from the drop-down menu.

l Select Create/Update AR Invoice to create an Accounts Receivable invoice

from a selected fee code. The invoice will be created in a new Invoices batch

in AR> Invoices.

l The batch number that will be used when creating invoices is specified

in the Starting Invoice Batch Number field on the CM Setup window

(CM> Utilities> Setup CM> Options section).

l If this batch number has already been committed in the current fiscal

period, the AR invoice will be created in the next available invoice

batch.

l If the batch has transactions in it but has not been committed, the new

invoice will be added to the batch and the batch will be returned to the

Enter Invoices step in AR> Invoices.
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l If the AR invoice that will be created in the batch has the same customer

number, account number, and issue number as an existing invoice in

the batch, the two invoices will be combined.

l This process is useful if you have an issue with multiple steps that

create AR invoices with different AR fee codes. This allows the

separate fee codes to be charged to a single customer account to

be charged on a single AR invoice.

l The address on the invoice will be pulled from the customer

account even if a lot is attached to the issue with a service

address that is different than the customer account address.

l The Citation Number field on the General tab of the Issue Main-
tenance window will populate the description of an AR invoice if

you have checked the Use Citation Number in Invoice Descrip-
tion toggle in CM> Utilities> Setup.

l Select UB Service Request to create an uncommitted service request in the

Utility Billing module for a selected service request code.

l The uncommitted service request will display in UB> Service

Requests> Input after the service request has been generated and the

issue step completed.

l You must attach a lot to the issue if you are going to create a UB service

request, and the UB account attached to the lot must be active. You

can view the status of a UB account on the UB Account Maintenance

window (UB> Maintenance> Account> Account tab> Customer Account

Information section> Status field).
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l The customer account attached to the lot will be the customer attached

to the service request.

l Select Create WO Work Order to use a recurring estimate to create a work

order in the Work Orders module.

l If the Action drop-down menu is empty, you can enable the AR, UB and WO

modules to interface with the Contact Management module on the CM Setup

window (CM> Utilities> Setup> Interfaces section).

l Enter an Action Item or click the field label to select a fee code or service request

code from a list. The contents of this list will depend on the selection in the Action

field.

l Fee codes are set up in AR> Maintenance> Fees.

l Service request codes are set up in UB> Maintenance> Service Request

Code.

l Recurring estimates are created and maintained on the Recurring Estimate

Maintenance window (WO> Recurring Estimates).

l The Action Item Description and Action Amount fields will populate after you

have selected a fee code or service request.

l The Description field will populate with the description of the fee code or ser-

vice request.

l If you are creating an AR invoice the Action Amount field will populate with the

Fixed Amount field of the fee code that is set up in AR> Maintenance> Fees>

Fee Code section. You can change the value in this field if desired.

l If you are creating a service request the Amount field will populate with the bil-

lable amount of the service request that is set up on the Service Request Main-

tenance window (UB> Maintenance> Service Request Code> Charge Info
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section> Default Charge field).

l The Default Charge field defaults to the Flat Amount set up in the spe-

cial charge code attached to the service request code, but this amount

can be modified without affecting the flat amount attached to the special

charge code. If you want to affect the flat amount of a special charge

code, that amount is set up in UB> Maintenance> Special Charge

Code> Charge Info section> Flat Amount field. If you change the flat

amount attached to the special charge code all Utility Billing trans-

actions attached to that special charge code will also be affected.

l The Completed Date and Completed Time fields will populate with the current

date and time when you click the Generate icon to generate an AR invoice or UB

service request.

l If there is no action attached to an issue step, you can close the step by com-

pleting the Completion Date and Completion Time fields.

l If you manually complete these fields the step will close and you will not be

able to process the action attached to the step.

l If you have accidentally closed a step you can create a new step by clicking

the Create icon . Make the new step identical to the step you accidentally

completed and click the Up or Down icons to move the new step to the

correct location.

l The Completed Time field will round down to the nearest half hour when an

action is performed and the step is closed.
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l Use the Scheduled Hours, Scheduled Date and Scheduled Time fields to record

information about how long the step should take and when the step should be com-

pleted.

l Enter any additional Step Notes for the issue step. This field can accommodate up

to 2000 characters.

4     Attach a Form to the step. 

l Click the Create icon drop-down menu and select New Form to add a new line

item in the Forms section.

l This allows you to add a form to a step so that you can print it out when processing

the issue.

l Forms are created and modified on the Forms Maintenance window (CM> Main-

tenance> Forms).

5    Complete the Contacts tab. 

l The Contacts tab allows you to attach a customer account to the issue. It is not

necessary to complete this tab to create an issue.

l Click the Create icon to add an additional contact to the issue.

CREATE AN ISSUE 16



l Contacts added to an issue will print in a section titled Issue Contacts on the printed

issue.

l Click the Customer Number field label to select a contact from a list. This will pop-

ulate and disable the other contact details with the information attached to the cus-

tomer account.

l A new contact may be entered on this tab that does not exist elsewhere in the

system.

l The Notes field allows you to attach notes to the contact information.

l This field does not display on the printed version of the issue or the Issue

Detail Listing Report, but it will be available as a field when the CM Query by

Example reporting tool is implemented.

l You can have up to five contacts attached to an issue and still be able to print all of

the contacts on a form.

l Click the View Data icon to open and edit an attached contact.

6     Complete the Comments tab. 

l The Comments tab allows you to attach comments to an issue. It is not necessary to

complete this tab to create an issue.

l Click the Create icon to add a comment to the issue type. Any additional com-

ments added to this tab will not affect the original issue type.

l Comment codes are created and maintained on the Comment Code Maintenance

window (CM> Maintenance> Comment Code).
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7     Complete the Miscellaneous tab. 

l The Miscellaneous tab will display the miscellaneous fields attached to the issue.

l The labels of the miscellaneous fields are set up in the Miscellaneous Field Labels

window (SS> Utilities> Miscellaneous Field Labels).

l Click the Save icon when complete.

8     Print the issue. 

l Click the Print icon to print the issue. You can view the progress of the job on the

Job Viewer window (SS> Utilities> Show Scheduled Jobs).

l Once the issue has been printed, you can also display the issue information

using the View Reports window (SS> Utilities> View Report).

l Click the Print icon drop-down menu and select Print Preview to preview the

report before printing.

l Click the Print icon drop-down menu and select Excel to export the report data

to an Excel spreadsheet as unformatted data.

l Click the Print icon drop-down menu and select Excel (Formatted) to export

the report data to an Excel speadsheet that includes much of the Springbrook

formatting found on the printed version of the report.
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CM> Issues> Issue Search

Issue Search

Summary

The Issue Search window is used to filter and search through all of the issues created in

the application. You can also create a new issue or open, modify and print an existing issue

from this window.

Step by Step

1     Open the Issue Search window (CM> Issues> Issue Search).

2     Filter the displayed Issues. 

l The Issue Search window will display all of the issues that have been created in the

application. Enter the desired issue information in the issue detail fields and click

the Refresh icon to filter the displayed issues by that value.

l Select an issue and click the Delete icon to delete that issue.

l Select an issue and click the Modify icon to open and modify that issue.
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l Click the Create icon to create a new issue.

l Right click in the data grid and select Export grid contents to Excel to export the

data grid information.

3     Print the issues. 

l Click the Print icon drop-down menu to select Print Issues or Print Issue Details.

l The Print Issues option will print the Issue Report.

l The Print Issue Details option will print the Issue Detail Report.

l Click the Print icon to process the report immediately or enter a date and time in

the field next to the Print icon to schedule the report to generate at a later time. You

can view the progress of the report on the Job Viewer window (SS> Utilities> Show

Scheduled Jobs).

l Click the Print icon drop-down menu and select Print Preview to preview the

report before printing.

l Click the Print icon drop-down menu and select Excel to export the report data

to an Excel spreadsheet as unformatted data.

l Click the Print icon drop-down menu and select Excel (Formatted) to export

the report data to an Excel spreadsheet that includes much of the Spring-

brook formatting found on the printed version of the report.

l Once the report is generated, you can also display the report using the View

Reports window (SS> Utilities> View Report).
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CM> Issues> Issue Step Search

Issue Step Search

Summary

The Issue Step Search window is used to filter and search through all of the issue steps cre-

ated in the application. Once an issue step is selected, you can also open, modify and print

the issue step from this window.

Step by Step

1     Open the Issue Step Search window (CM> Issues> Issue Step Search).

2     Filter the displayed Issues. 

l The Issue Step Search window will display all of the issues steps that have been cre-

ated in the application. Enter the desired issue information in the issue detail fields

and click the Refresh icon to filter the displayed issues by those values.

l Highlight an issue and click the Modify icon to open the Issue Maintenance win-

dow.
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3     Edit the selected issue. 
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CM> Maintenance> Comment Code

Comment Code Maintenance

Summary

Comments can be attached to customers to track any notes about the customer including

phone conversations, complaints and requests. Comments are added to CM Issue Types

in the Issue Type Maintenance window (CM> Maintenance> Issue Type> Open an Issue

Type> Comments tab).

Step by Step

1     Open the Comment Code Maintenance window (CM>Maintenance> Comment Codes). 

l The Comment Code Maintenance window will display a list of all the comment

codes created in the application.

l Click the Delete icon to delete a comment code. You cannot delete comment

codes that are attached to customer accounts.

l Click on the Create icon to add a new comment code.
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2     Create a comment code. 

l Enter a unique code in the Comment Code field. This code can be up to 20 alpha-

numeric characters. This field will not be enabled and available for editing after the

comment code has been saved.

l Enter a description in the Description field. The Description can be up to 60 alpha-

numeric characters.

l Click on the Save icon or hit the ENTER key to save the comment code.
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CM> Maintenance> Forms

Form Maintenance

Summary

Forms refer to Microsoft Word documents that, through the use of merge fields, allow users

to pull data from the application and customize how that data is displayed on the forms.

Forms will be saved in the Springbrook folder on your server at the path specified when the

application was installed (SS> Utilities> System Setup> System tab> Archive Directory
field).

The forms will be saved as .sbw files in this folder and should not be edited to avoid cor-

ruption. Forms can be attached to various application elements through the module pro-

cess and maintenance palettes.

Follow this process to create forms to attach to steps in issues or issue types. The forms

set up in the Contact Management module will not be accessible in other modules that use

forms.

Step by Step

1     View existing Forms. 

FORM MAINTENANCE 25



l Open theWord Merge Form Selection window (CM> Maintenance> Forms).

l The Word Merge Form Selection window will display all of the forms created in the

application. Use the search criteria fields to filter the displayed forms.

l Highlight a form and click the Preview icon to view the selected form. This will

open the MS Word document in a new window.

l Highlight a form and click the Copy icon to copy the selected form. This will cre-

ate a copy of the original form.

l Highlight a form and click the Delete icon or press DELETE to delete the selec-

ted form.

l Highlight a form and click the Modify icon or press ENTER to open and edit an

existing form.

l Click the Create icon or press INSERT to create a new form. This will open the

Word Merge Form Maintenance window.

2     Create a Form. 

l Enter a unique Form Name for the form. The field can be up to 32 characters long.

Once the form has been saved, you will not be able to edit this field.

l Enter an optional form Description.
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l After you have entered a form name and description, click the Create icon to cre-

ate the form. This will open a Word document.

l Once the Word document is open, use the insert merge fields command in

Word to specify the data fields you want displayed on the form. By inserting a

merge field into the Word document, and then attaching the form to a CM

issue, the form will display the data found in the corresponding field of the cus-

tomer attached to the issue.

l Images, charts, tables, etc. can also be inserted into the Word document.

l Once you are finished creating/modifying your form, be sure to save the form both

on the Word document (File> Save) and using the Save icon on the Form Main-

tenance window.

l The new form will now be available when creating form letters in the specified CM

process.
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CM> Maintenance> Issue Status

Create an Issue Status

Summary

The issues status can be used to filter issues in Contact Management reports and is a

required field when creating issues (CM> Issues> Issue Search).

Step by Step

1     View existing issue statuses. 

l Open the Issue Status Maintenance window (CM> Maintenance> Issue Status).

l The left section of the window will display all of the issue statuses that have been

created in the application. Select an issue status in the left section of the window

and the information attached to that issue status will populate in the Maintenance

section to the right.

l Highlight an issue status and press DELETE or click the Delete icon if you would

like to delete an issue status.

l You cannot delete an issue status that is attached to an Issue Type. If you try

to delete an issue status that is attached to another record, an information
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window will open displaying the record it is attached to.

l Press INSERT or click the Create icon if you would like to create a new issue

status. This will create a new line item in the left section of the window and the fields

in the Maintenance section to the right will be enabled to enter the issue status

information.

2     Create or modify an issue status. 

l The Status field is used to create the issue status code. The status code can be up

to 20 alphanumeric characters long.

l This is the only required field in the window. All other fields are optional.

l You will not be able to edit an existing issue status field.

l The issue status will display on the printed version of the issue.

l The Description field is used to enter a description on the issue status. The descrip-

tion can be up to 60 characters long.

l Press ENTER or click the Save icon to save the issue status.
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CM> Maintenance> Issue Type

Issue Type Maintenance

Summary

In order to create a Code and Contact Management issue, you must first set up issue types

which act as templates when creating issues. When an issue type is attached to an issue it

will populate the fields of the issue with default values set up on the issue type. Issue types

reduce data entry and data error and allow similar issues to be processed in a uniform man-

ner. You should set up an issue type for each issue that you expect to be a recurring issue

to ensure that the issues will be processed in the same way and with consistent inform-

ation.

Step by Step

1     Open the Issue Type Selection window (CM>Maintenance> Issue Type). 

l The Issue Type Selection window will display all of the existing Issue Types in the

application.

l Enter the desired issue type information and click the Refresh icon to filter the

displayed issue types.
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l Highlight an issue type and click the Copy icon to create a copy of the selected

issue type.

l Click the Delete icon to remove an issue type. If issues have been created from

this issue type you will not be able to delete the issue type.

l Highlight an issue type and click the Modify icon to edit the selected issue type.

l Click the Create icon to create a new issue type. This will open the Issue Type

Maintenance window.

2     Create a new Issue Type. 

l The General Tab displays the basic Issue Type information.

l Complete the Issue Type section.

l Enter an Issue Type name. The type name can be up to 30 characters long.

l Once you have created and saved a new issue type you cannot modify

the type field.

l Enter an issue type Description. The description can be 100 char-
acters long.

l If you check the Use Citation Number in Invoice Description

toggle in CM> Utilities> Setup CM> Options section, the citation

number field will populate in the description field of an AR Invoice.
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l Check the Inactive toggle if you do not want this issue type to be act-
ive. This will keep the issue type from being used when creating new

issues.

l Changing an issue type to inactive will not keep issues that have

already been created and attached to this issue type from being

processed. It will only keep future issues from being attached to

this issue type.

l Complete the Issue Template section.

l Enter an Issue Status or click the field label to select one from a list. This is

the initial value of an issue of the selected issue type. This field can be mod-

ified when the issue is being created.

l Statuses are user defined and set up on the Issue Status window (CM>

Maintenance> Issue Status). This is a required field.

l The Issue Description is a large text field used to provide a description for

the issue. This field can be up to 2000 characters, so you can provide an

extensive Issue Description.

l The Ordinance field is a large text field that can be used to enter the ordin-

ance number of an issue. This field is not required but will display on the prin-

ted version of the issue.

l The Notes field can be used for general notes and will display on the printed

version of the issue.

l If you are creating a work order in an issue step, the value in this field

will display in the Notes field on the General tab of the created Work

Order estimate.
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l The labels of the user defined miscellaneous fields in the Issue Template sec-

tion are set up on the Miscellaneous Field Labels Maintenance window (SS>

Utilities> Miscellaneous Field Labels).

l These fields can be used in reporting with the QBE reporting tool (CM>

Reports> QBE Report). The user defined miscellaneous fields will show

up in the Issue Master table labeled as User Char 1, User Char 2, User

Dec 1, User Dec 2, User Date 1, User Date 2, User Log 1, and User Log

2.

3     Complete the Steps tab. 

l Steps allow you to send the issue from queue to queue or to Springbrook users.

Steps also allow you to create AR invoices, UB service requests and WO work

orders.

l The steps you set up on this tab are only defaults. When creating a specific issue on

the Issue Search window (CM> Issues> Issue Search), you will be able to modify

the default steps of the issue type.

l Incomplete steps will display in red.

l Click the Create icon drop-down menu and select New Step to add a new step

to the issue type. This will enable the Detail section.

l Enter a Step Description for the step. This is a required field that is 500 characters

in length, but only the first 30 characters will display on the Issue Detail Listing

Report.
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l The Notification Recipient drop-down menu is used to specify who will be notified

when the step requires attention.

l Select a Queue from the drop-down menu. This is the queue that the issue is sent to

in the step.

l Queues are set up on the Queue Maintenance window (CM> Maintenance>

Queues). If you create a new queue with the Issue Type Maintenance window

open, the new queue will not display on the Queue Selection window until you

save the issue type and reopen the window.

l Enter a Role or click the field label to select one from a list if you want to assign this

step to a specific role.

l Select a User from the drop-down menu if you want to assign this step to a specific

Springbrook user in the selected Queue.

l Only Springbrook users that are attached to a queue will display in the drop-

down menu.

l Springbrook users are attached to queues in CM> Maintenance> Queues. If

you add a new Springbrook user to a queue the new user will not display in

the Issue Type Maintenance window unless you save the issue type and

reopen the window.

l The Scheduled Hours drop-down menu is used to create a schedule for the step.

l Select an Action from the drop-down menu.

l Select Create/Update AR Invoice to create an Accounts Receivable invoice

from a selected fee code. The invoice will be created in a new Invoices batch

in AR> Invoices.

l The batch number that will be used when creating invoices is specified

in the Starting Invoice Batch Number field on the CM Setup window
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(CM> Utilities> Setup CM> Options section).

l If this batch number has already been committed in the current fiscal

period, the AR invoice will be created in the next available invoice

batch.

l If the batch has transactions in it but has not been committed, the new

invoice will be added to the batch and the batch will be returned to the

Enter Invoices step in AR> Invoices.

l If the AR invoice that will be created in the batch has the same customer

number, account number, and issue number as an existing invoice in

the batch, the two invoices will be combined.

l This process is useful if you have an issue with multiple steps that

create AR invoices with different AR fee codes. This allows the

separate fee codes to be charged to a single customer account to

be charged on a single AR invoice.

l The address on the invoice will be pulled from the customer

account even if a lot is attached to the issue with a service

address that is different than the customer account address.

l The Citation Number field on the General tab of the Issue Main-
tenance window will populate the description of an AR invoice if

you have checked the Use Citation Number in Invoice Descrip-
tion toggle in CM> Utilities> Setup.

l Select UB Service Request to create an uncommitted service request in the

Utility Billing module for a selected service request code.

l The uncommitted service request will display in UB> Service

Requests> Input after the service request has been generated and the
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issue step completed.

l You must attach a lot to the issue if you are going to create a UB service

request, and the UB account attached to the lot must be active. You

can view the status of a UB account on the UB Account Maintenance

window (UB> Maintenance> Account> Account tab> Customer Account

Information section> Status field).

l The customer account attached to the lot will be the customer attached

to the service request.

l Select Create WO Work Order to use a recurring estimate to create a work

order in the Work Orders module.

l If the Action drop-down menu is empty, you can enable a module to interface

with the Contact Management module on the CM Setup window (CM> Util-

ities> Setup> Interfaces section).

l If you change the interface options while the Issue Type Maintenance window

is open, you must save and reopen the window to update the changes.

l Enter an Action Item or click the field label to select a fee code, service request

code or recurring estimate from a list. The contents of this list will depend on the

selection in the Action field above.

l Fee codes are set up in AR> Maintenance> Fees.

l Service request codes are set up in UB> Maintenance> Service Request

Code.

l Recurring estimates are set up in WO> Recurring Estimates.

l The Action Item Description and Action Amount fields will populate after you

have selected a fee code, service request or recurring estimate.
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l The Description field will populate with the description of the fee code, service

request or recurring estimate.

l If you are creating an AR invoice the Action Amount field will populate with the

Fixed Amount field of the fee code that is set up in AR> Maintenance> Fees>

Fee Code section. You can change the value in this field if desired.

l If you are creating a service request the Amount field will populate with the bil-

lable amount of the service request that is set up on the Service Request Main-

tenance window (UB> Maintenance> Service Request Code> Charge Info

section> Default Charge field).

l The Default Charge field defaults to the Flat Amount set up in the spe-

cial charge code attached to the service request code, but this amount

can be modified without affecting the flat amount attached to the special

charge code. If you want to affect the flat amount of a special charge

code, that amount is set up in UB> Maintenance> Special Charge

Code> Charge Info section> Flat Amount field. If you change the flat

amount attached to the special charge code all Utility Billing trans-

actions attached to that special charge code will also be affected.

l The Step Notes field is a large text field used to add notes to the step.

l Once the steps are created, click the Up and Down icons to change the

order of the steps. The issues attached to this issue type will begin in the step at the

top of the window. The step order also displays in the Order column of the Steps sec-

tion.

4     Attach a Form to the step. 
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l Click the Create icon drop-down menu and select New Form to create a new

line item in the Forms field.

l This allows you to add a form to a step so that can be printed when processing the

issue.

l Add any optional Notes about the form if desired.

l Forms are created and modified on the Forms Maintenance window (CM> Main-

tenance> Forms).

5     Complete the Contacts tab. 

l The Contacts tab allows you to attach a customer account to the issue type. It is not

necessary to complete this tab to create an issue type.

l Contacts added to an issue will print in a section titled Issue Contacts on the printed

issue.

l Click the Create icon to create a new line item and activate the Maintenance section

of the window below.

l A new contact may be entered on this tab that does not exist elsewhere in the

system.

l Click the Customer Number field label to specify an existing customer as the new

contact.

ISSUE TYPE MAINTENANCE 38



l The Notes field allows you to attach notes to the contact information.

l This field does not display on the printed version of the issue or the Issue

Detail Listing Report, but you will be able use it in reporting when the QBE

reporting tool is implemented. This field will be titled Notes and will be found in

the Issue Contact secondary table.

l You can have up to five contacts attached to an issue and still be able to print all of

the contacts on a form.

l Click the Save icon to add the contact to the issue type.

6     Complete the Comments tab. 

l The Comments tab allows you to attach comments to an issue type. It is not neces-

sary to complete this tab to create an issue type.

l The comments added to this tab will be pulled into every issue of this issue type.

l Click the Create icon to add a comment to the issue type.

l This will open the Comment Code Selection window. Comment codes are cre-

ated and maintained on the Comment Code Maintenance window (CM> Main-

tenance> Comment Code).

l Highlight the desired comment code and click the Confirm icon the return

the comment code to the tab.
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l The Comments tab will now be split into two sections.

l The left section will display the comment codes attached to the issue type.

The Comment Code, Comment, User name, Date Created and Date Closed

will be displayed for each line item.

l The right section will display the editable detail fields associated with each

line item.

l Change the selected comment code by entering a new comment code in the

Code field or by clicking the Code field label and selecting a new comment

code from a list.

l Enter the desired comment in the Comment field. This comment can be up to

512 characters long.

l The Date Created field will default to today's date.

l Enter a Date Closed when the issue associated with the comment has been

addressed.

l Click the Save icon when complete.
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CM> Maintenance> Query by Example

Create a QBE Report in CM

Summary

The QBE Builder reporting tool is used to create customized reports in the Code and

Contact Management module. Reports are created in the QBE Builder by selecting

columns, creating arguments to remove records (Transaction Date < 01/01/2021), select-

ing how the report will group and sort, and then defining the totals that will display on the

report. After the report has been created, it can be printed out or exported into an MS

Excel, MS Access or CSV format. Reports that have been created using the QBE Builder

tool can be saved and generated at any point.

This document will cover how to create a specific example report that provides an explan-

ation of primary tables, secondary tables, arguments and totals. When creating your own

QBE reports, it is helpful to know the general structure of the database and how the inform-

ation entered into the fields on a window will be stored in the database fields and tables.

The Table/Field help feature (Help> Table/Field) is designed to be used in conjunction with

database security (SS> Security> DB Security), but it can be helpful when building QBE

Reports to help you determine where the information entered into a field on a window is

stored. This tool will not always be helpful because it will display the exact name of the

table and field where the information is stored, but QBE Builder uses simplified and more

intuitive field and table names.
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The report we will create in this example is a report that displays issue steps that have

been scheduled before a certain date but have not been completed yet. This report could

be used to locate issue steps that should have been completed but have not. Every module

with a QBE reporting tool offers a different example report, so if the report you want to cre-

ate is different than the report created in this example, refer to the QBE examples in other

modules for more help. The QBE Report feature works the same in all of the modules, but

the information that is available to report on is different from module to module.

Step by Step

1     View the QBE Reports. 

l Open the QBE Maintenance window (CM> Maintenance> Query by Example).

l The QBE Maintenance window will display all of the reports that have been created

in the CM module. Select a report in the left section of the window and the cus-

tomized report information will populate in the right section of the window just like

many of the other maintenance windows in the application.

l Highlight a report and press DELETE to delete the highlighted report.

l Click the Create icon or press INSERT to create a new QBE report.

l Highlight a report and click the Print icon to print an existing QBE report. The

QBE report will be generated as soon as the resources are available on the server.

You can view the progress of the print job using the Jobs Viewer window (Jobs

Viewer icon on the main application window).
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l Highlight a report and click the Export icon drop-down and select Export Report

to export the highlighted report data.

l Highlight a report and click the Export icon drop-down and select Export Defin-

ition to export the report definitions of the highlighted report. This exported report

definition file can then be imported using the Import icon . This allows organ-

izations to share QBE reports.

2     Select the tables that contain the information you would like to include on the report. 

l The first step in creating a customized report is selecting the information you would

like to display on the report. Information in a database is organized into tables and

fields. Fields are used to store specific information, such as customer names. Fields

are then grouped into tables. For example, a grouping could consist of a customer

table that contains all of the general customer information, such as address and

phone number. When information is entered into a window in the application, that

information is stored in a specific field within a specific table. When creating a QBE

report, select the tables that contain the information you would like to include on the

report and then select the fields.

l Select a table from the Table Name drop-down menu in the Primary Table section.

The Available Fields section will populate with the fields grouped into that table. If

the table you select does not contain all of the fields you want to report on you will

have to select a secondary table.
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l Some tables in the database are linked together because they share a common

field called a key. The key connects the data in the two tables together and defines

how the data in one table is related to the data in another table. If the table you

selected in the Table Name drop-down menu in the Primary Table section is linked

to other tables, you can select a secondary table in the Secondary Table section. As

you select a secondary table from the Table Name drop-down menu, new fields will

be added at the bottom of the Available Fields section. If you need information from

two different tables, but those tables are not linked together, you will not be able to

create the report.

l From the Table Name drop-down menu in the Primary Table section, select Issue

Master.

l From the Table Name drop-down menu in the Secondary Table section, select

Issue Steps. This table contains the step information of each issue.

3     Select the fields you would like to include in the report. 

l After you have selected the tables you can pull the fields from those tables onto the

report. Check the toggles of the fields you would like to include on the report in the

Available Fields section. Only fields with a check will display on the report.

l In the Available Fields section, check the Issue Number toggle for the Primary

Table. This is the primary column that will display in the report. Check the Step,

Description, Scheduled Date, and Completed Date toggles for the Secondary Table.

Be sure the Description toggle you check is associated with the Secondary Table.

Secondary Table fields will display the Secondary Table icon .
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4     Create a filter argument for the report. 

l The fields below the Table Name drop-down menu are used to create an argument

that will filter the information that will display on the report.

l While many reports will be filtered by the Primary Table, our example will only be

filtered by the Secondary Table. The process for entering arguments is the same for

both tables. These arguments are limited to 2048 characters.

l Enter the arguments in the Secondary Table section.

l When you enter an argument in the Primary Table and the Secondary Table

section the arguments will be joined with an AND statement, meaning records

must meet the conditions in both section before they will display on the report.

This is the part of the argument that will filter to report to only include issues

steps that have a “0” in the Completion Time field.

l Select Completed Time from the first drop-down menu directly below

the Table Name field. Selecting a value for this field activates the two

fields to the right.

l The next field contains the operators that will give the argument mean-

ing. Select Equals from this drop-down menu.

l Enter 0 in the third argument field.

l Click the Add button to save the argument to the Secondary Table field.

l Click the Test Query icon to confirm that the query is valid.

l The AND and OR buttons will be enabled after you add the argument to the

report. The AND and OR buttons are used to link the conditions of an
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argument together so you can build more complicated filtering. The second

part of our argument will filter the report to only include issue steps with a

value in the Scheduled Date field that is before a certain date. If you are cre-

ating a report to display all issue steps that should have been completed the

previous day, then we can enter that date into the filter.

l Select Scheduled Date in the first drop-down menu directly below the

Table Name field. Selecting a value for this field activates the two fields

to the right.

l The next field contains the operators that will give the argument mean-

ing. Select Less Than from this drop-down menu.

l Enter the previous day's date the third argument field.

l Click the Add button to save the second argument to the Secondary

Table field.

l Click the Test Query icon to confirm that the expanded query is

valid.

l Our query ensures that all steps with a scheduled date before the

entered date that have a completed time of zero will display in the

report.

l The brackets are used to define the order in which the AND and OR

statements will be applied. Arguments within brackets will be calculated

before arguments outside of brackets. For example, you can create an

OR statement inside an AND statement using the following format:

(statement 1 OR statement 2) AND (statement 3 OR statement 4). The

OR statements inside the brackets will be processed first, and then the

AND statement will be applied. We will not be using the brackets in our
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example.

5     Set the number of records that will display on the report. 

l The Limit field in the Primary Table section is used to define the maximum number

of records that will display on the report. If you set this value to a very large number

(99,999,999,999) you run the risk of creating a report that will take a long time for

your server to process. If you set this value too low, you risk excluding results that

meet the filter argument requirements.

l Enter 100 in the Limit field to limit our incomplete issue steps report to 100 results. If

this produces a report with 100 results, you may want to adjust this number up in

order to be sure that all results are included.

6     Modify the report layout. 

l After the fields have been selected and the arguments have been entered on the

report you are ready to set up the report layout. The report layout allows you to

define how the report will be grouped and totaled, and also allows you to select

which fields will total.

l Click the Modify Report Layout icon to open the QBE Layout window.

l Move the columns that display in the QBE Report Layout section to change the

order in which the information will display on the report.
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l Move column headings to the section above the column headings to change how

the information is grouped on the report.

l The Column Totals section is used to select which columns should be totaled on

the report. Check the toggle of the totals you would like to include on the report.

l Only columns that would provide a meaningful total will be available in the

Column Totals section.

l Our example does not include any columns that would provide a meaningful

total.

l Click the Save icon when complete to save the report layout. The QBE report

will print in the saved format when the report is generated.

7     Save the report. 

l Enter a name for the report in the Report Name field.

l Click the Save icon when complete.

8     Print or export the report. 

l Click the Print icon to generate the report. You can view the progress of the

report on the Job Viewer window (SS> Utilities> Show Scheduled Jobs).
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l Click the Print icon drop-down menu and select Print Preview to preview the

report before printing.

l Click the Print icon drop-down menu and select Excel to export the report data

to an Excel spreadsheet as unformatted data.

l Click the Print icon drop-down menu and select Excel (Formatted) to export

the report data to an Excel spreadsheet that includes much of the Spring-

brook formatting found on the printed version of the report.

l Once the report is generated, you can also display the report using the View

Reports window (SS> Utilities> View Report).

l Click the drop-down arrow next to the Export icon to select the export format. A

window will open allowing you to select the path where the exported file will be cre-

ated.

l If your report appears to be missing information but your filters seem to be correct,

make sure the Limit field in the Primary Table section contains a large enough num-

ber to contain all of the records you want to include in the report.
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CM> Maintenance> Queue

Queue Maintenance

Summary

Follow this process to create a queue. Queues are assigned to issues on the Step tab of

the Issue Maintenance window.

Selecting a Queue allows the user to specify the departments that could initially take the

service or code call, as well as the other departments that may handle individual pieces of

a service or the code violation process.

Step by Step

1     Open the Queue Selection window (CM> Maintenance> Queue). 

l The Queue Selection window will display all of the existing Queues in the applic-

ation.

l Enter the desired queue information and click the Refresh icon to filter the dis-

played queues.
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l Click the Delete icon to remove a highlighted queue. You will not be able to

delete a queue that is attached to one or more Issue Steps.

l Highlight a queue and click the Modify icon to edit the selected queue.

l Click the Create icon to create a new queue. This will open the Queue Main-

tenance window.

2     Create a new queue. 

l Enter a Queue name. This is the name that will be used to recognize the queue

when selecting it.

l This field can be up to 20 characters long.

l Once you save the new queue, you will not be able to modify this field.

l Enter a queue Description.

l The description field can be up to 60 characters long.

l The Queue Members section is used to add Springbrook users to the queue. You

must have at least one user attached to a queue.

l Only Springbrook users attached to a queue will be available in the User field

when that queue is attached to an issue step.

l Click the Create icon to add a new user to the queue. This will open

a list of users to select from. The user information will display in the win-

dow.

QUEUE MAINTENANCE 51



l The Administrator default user account cannot be assigned to

queues.

l The queue administrator functions as the user who received

notice when there are errors or issues generated by actions cre-

ated from that queue. The queue administrator will receive a

Springbrook Messaging System message when AR invoices are

deleted that have been created from issues processed in that

queue.

l To make a user the queue administrator, check the Queue
Admin toggle.

l If the Enable Queue Restrictions toggle is checked on the

CM Setup window (CM> Utilities> Setup), only Springbrook

users attached to a queue and designated as the Admin-

istrator will be able to attach that queue to an issue step.

l To delete a user from the queue, highlight the user and click the Delete

icon .

l If you delete a user from a queue that is attached to an issue type,

the issue type will update and remove the user from the queue.

The issue type will not assign a new user to the step, you will have

to go in and manually add a new user.

l Open issues will not update with the deleted user.

l Click the Save icon when complete.
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CM> Maintenance> Resolution Type

Resolution Type Maintenance

Summary

Resolutions are attached to completed issues on the Issue Maintenance window (CM>

Issues> Issue Search> Open an issue> Resolution Type field). Resolution types can also

be used to filter reports. The resolution type will display on the printed issue and the Issue

Detail Report.

Step by Step

1     View existing Resolution Types. 

l Open the Resolution Type window (CM> Maintenance> Resolution Type).

l The left section of the window will display all of the resolution types that have been

created in the application. Select a resolution type in the left section of the window

and the information attached to that resolution type will populate in the Maintenance

section to the right.

l Highlight a resolution type and press DELETE or click the Delete icon if you

would like to delete a resolution type.
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l You cannot delete a resolution type that has been attached to an issue. If you

try to delete a resolution type that is attached to an issue, an error window will

display.

l Press INSERT or click the Create icon if you would like to create a new res-

olution type. This will create a new line item in the left section of the window and the

fields in the Maintenance section to the right will be enabled to enter the resolution

type information.

2     Create or modify a Resolution Type. 

l The Resolution Type field is used to create the resolution type code. The res-

olution type code can be up to 20 alphanumeric characters long.

l This is the only required field in the window. All other fields are optional.

l You will not be able to edit an existing resolution type field.

l The Description field is used to enter a description on the resolution type. The

description can be up to 60 characters long.

l Press ENTER or click the Save icon to save the resolution type.
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CM> Maintenance> Web Approvals

Web Approvals Maintenance

Summary

The Web Approval Maintenance window is used to display issues submitted through the

Online Code and Contact Management application and processed through the Web

Approvals batch process. This is a read-only window.

Step by Step

l TheWeb Approval Maintenance window (CM> Maintenance> Web Approvals) will display

any user-submitted issues that have been processed through the Web Approvals batch pro-

cess.

l Enter the desired web approval information and click the Refresh icon to filter the dis-

played web approvals.

l Highlight a web approval and click the Modify icon or press ENTER to open a read-only

version of the selected web approval.
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CM> Maintenance> Web Source

Web Source Maintenance

Summary

The Web Source Maintenance window is used to maintain the contact information for indi-

viduals that create Online Code and Contact Management accounts in order to submit an

issue. Because web sources can only be created through the online application, this win-

dow is only used to maintain existing web sources.

Step by Step

1     Open the Web Source Selection window. 

l TheWeb Source Selection window (CM> Maintenance> Web Source) will display

all of the existing web sources in the application.

l Web sources can only be created through the Online Code and Contact Man-

agement application.

l Enter the desired web source information and click the Refresh icon to filter the

displayed web sources.
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l Highlight a web source and click the Modify icon or press ENTER to edit the

selected web source. This will open the Web Source Maintenance window.

2     Maintain Web Sources. 

l The Email address field is the only field on the Web Source Maintenance window

that cannot be edited from within Springbrook. If a web source needs to update their

email address, they must log in to the Online Code and Contact Management applic-

ation and update their user profile.

l Make any desired edits to the contact information and click the Save icon to

save the changes.
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CM> Reports> Issue Detail

Issue Detail Report

Summary

The issue detail report displays the steps of an issue and the scheduled and completed

times of those steps. You can also run this report from the Issue Search window (CM>

Issues> Issue Search).

Step by Step

1     Open the Issue Detail Report window (CM> Reports> Issue Detail).

2     Configure the report. 

l Select the Issue Types to include in the report. Press CTRL+A and SPACE to high-

light and select all the Issue Types displayed.

l Issue Types are set up on the Issue Type Maintenance window (CM> Main-

tenance> Issue Types) and attached to issues when they are created.

l Select an Issue Status to include in the report. Press CTRL+A and SPACE to high-

light and select all the Issue Statuses displayed.
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l Issue statuses are set up on the Issue Status Maintenance window (CM>

Maintenance> Issue Status) and attached to issues when they are created.

l Select an Issue Resolution to include in the report. Press CTRL+A and SPACE to

highlight and select all the Issue Resolutions displayed.

l Issue resolutions are set up on the Issue Resolution Maintenance window

(CM> Maintenance> Resolution Type) and attached to issues when they are

completed.

l Enter an issue number in the From Issue Number and To Issue Number fields to

filter the report by a range of issue numbers.

l The issue number is a sequential number assigned to the issue as it is cre-

ated.

l You can leave the To Issue Number field blank to include all issues with an

issue number greater than the issue number entered in the From Issue Num-

ber field.

l Enter a Citation number in the From Citation Number and To Citation Number

fields to filter the report by a range of citation numbers.

l You can leave the To Citation Number field blank to include all issues with a

citation number greater than the citation number entered in the From Citation

Number field.

l You may get more than one issue per citation number if you have not set up

your Contact Management module to force unique citation numbers by check-

ing the Enforce Unique Citation Numbers toggle (CM> Utilities> Setup).

l The report will display all issues with the citation numbers included in the

range, including those that have more than one issue per citation number.
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l The Citation Number fields may display different labels if you have edited the

labels on the Miscellaneous Field Label Maintenance window (SS> Utilities>

Miscellaneous Field Labels).

l Enter a date in the From Issue Date and To Issue Date fields to filter the report by

an issue date range.

l If you leave the To Issue Date field blank, the report will include all issues with

an issue date after the date entered in the From Issue Date field.

l The issue date defaults to the date the issue is created on the Issue Main-

tenance window (CM> Issues> Issues Search> Create icon). This date can-

not be modified when the issue is being created.

l Enter a Source Customer Number or click the field label and select one from a list

to filter the issues that display in the report by source customer.

l The Source customer is the customer that initiated the issue, and is attached

to an issue on the Issue Maintenance window (CM> Issues> Issue Search>

Create icon> Source Customer Number field).

l Enter a Target Customer Number or click the field label and select one from a list

to filter the issues that display in the report by issue customer.

l The Issue customer is the customer that the issue concerns and is the cus-

tomer that will be charged for an AR invoice or billable UB service request.

Some issues may not have a customer attached to them.

l Enter a Target Lot Number or click the field label and select one from a list to filter

the issues that display in the report by issue lot.

l The target lot number is the lot attached to the issue. Some issues may not

have a lot attached to them.
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l The Issue Detail report will display the issue number, citation number, issue date,

issue type attached to the issue, issue status, and the resolution if the issue has

been completed. The report will also display the step number and description,

scheduled date, and completion date if the step is complete.

3     Print the report. 

l Click the Print icon to process the report immediately or enter a date and time in

the field next to the Print icon to schedule the report to generate at a later time. You

can view the progress of the report on the Job Viewer window (SS> Utilities> Show

Scheduled Jobs).

l Click the Print icon drop-down menu and select Print Preview to preview the

report before printing.

l Click the Print icon drop-down menu and select Excel to export the report data

to an Excel spreadsheet as unformatted data.

l Click the Print icon drop-down menu and select Excel (Formatted) to export

the report data to an Excel spreadsheet that includes much of the Spring-

brook formatting found on the printed version of the report.

l Once the report is generated, you can also display the report using the View

Reports window (SS> Utilities> View Report).
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CM> Reports> Print Issue

Print an Issue

Summary

The Print Issue report will create a printed version of each issue. You can run this report

from the Issue Search window (CM> Issues> Issue Search) and from the Print Issue win-

dow (CM> Reports> Print Issue).

Step by Step

1     Open the Print Issue window (CM> Reports> Print Issue or CM> Issues> Issue

Search> Print icon ).

2     Configure the report. 

l Select the Issue Types to include in the report. Press CTRL+A and SPACE to high-

light and select all the Issue Types displayed.

l Issue Types are set up on the Issue Type Maintenance window (CM> Main-

tenance> Issue Types) and attached to issues when they are created.
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l Select an Issue Status to include in the report. Press CTRL+A and SPACE to high-

light and select all the Issue Statuses displayed.

l Issue statuses are set up on the Issue Status Maintenance window (CM>

Maintenance> Issue Status) and attached to issues when they are created.

l Select an Issue Resolution to include in the report. Press CTRL+A and SPACE to

highlight and select all the Issue Resolutions displayed.

l Issue resolutions are set up on the Issue Resolution Maintenance window

(CM> Maintenance> Resolution Type) and attached to issues when they are

completed.

l Enter an issue number in the From Issue Number and To Issue Number fields to

filter the report by a range of issue numbers. Click the field labels to open an issue

number selection window.

l The issue number is a sequential number assigned to the issue as it is cre-

ated.

l You can leave the To Issue Number field blank to include all issues with an

issue number greater than the issue number entered in the From Issue Num-

ber field.

l Enter a Citation number in the From Citation Number and To Citation Number

fields to filter the report by a range of citation numbers.

l You can leave the To Citation Number field blank to include all issues with a

citation number greater than the citation number entered in the From Citation

Number field.

l You may get more than one issue per citation number if you have not set up

your Contact Management module to force unique citation numbers by check-

ing the Enforce Unique Citation Numbers toggle in CM> Utilities> Setup.
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l The report will display all issues with the citation numbers included in the

range, including those that have more than one issue per citation number.

l The Citation Number fields may display different labels if you have edited the

labels on the Miscellaneous Field Label Maintenance window (SS> Utilities>

Miscellaneous Field Labels).

l Enter a date in the From Issue Date and To Issue Date fields to filter the report by

an issue date range.

l If you leave the To Issue Date field blank, the report will include all issues with

an issue date after the date entered in the From Issue Date field.

l The issue date defaults to the date the issue is created in CM> Issues> Issues

Step Search. This date cannot be modified when the issue is being created.

l Enter a Source Customer Number or click the field label and select one from a list

to filter the issues that display in the report by source customer.

l The Source customer is the customer that initiated the issue, and is attached

to an issue on the Issue Step Search window (CM> Issues> Issue Step

Search> Source section> Customer Number field).

l Enter a Target Customer Number or click the field label and select one from a list

to filter the issues that display in the report by issue customer.

l The Issue customer is the customer that the issue concerns and is the cus-

tomer that will be charged for an AR invoice or billable UB service request.

Some issues may not have a customer attached to them.

l Enter a Target Lot Number or click the field label and select one from a list to filter

the issues that display in the report by issue lot.

l The target lot number is the lot attached to the issue. Some issues may not

have a lot attached to them.
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l The issue will print on more than one page if there are many different issue steps or

extensive notes in the Detail Notes field on the Steps tab.

l The Issue will display all of the fields from the General tab and the information on

each step of the issue.

l The address fields in the issue Target section is the address of the lot. If there

is no lot attached to the issue the address field will be empty.

l The User Name field displays the Springbrook user who was attached to the

step.

l The Scheduled Date and Scheduled time fields will display the date and time

that the steps of an issue were initially scheduled to begin.

l The Description field will display the contents of the Description field on each

individual step.

l The Notes field in the Issue Step section is pulled from the Step Notes section

of the Issue Maintenance Steps tab.

l The Queue and Role fields will display the Queue and Role attached to the

step.

l The Completed Date and Completed Time fields will display the date and time

the steps of an issue are completed.

l If there is an action in the issue step, the date and time fields will pop-

ulate when you click the Generate icon .

l If there is no action in the issue step, you can manually enter a com-

pletion time and date to complete the issue step.
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l The Action field is the module that the step is affecting with the action it is per-

forming. If there is no module name in the field there is no action being per-

formed by the step.

l The Action Description field displays the process that will be performed by the

step.

l If the step is creating an Accounts Receivable invoice, the Interface

Description field will display the AR fee code and fixed amount of the

fee.

l AR fee codes are set up in AR> Maintenance> Maintain Fees.

l If the step is creating a Utility Billing service request the service request

code will display in the Interface Description field.

l Service request codes are set up in UB> Maintenance> Service

Request Code.

l The Action Status field displays the status of the action being performed by

the step. If the action has been performed the service request number or

invoice number created by the issue step will display in the field.

3     Print the report. 

l Click the Print icon to process the report immediately or enter a date and time in

the field next to the Print icon to schedule the report to generate at a later time. You

can view the progress of the report on the Job Viewer window (SS> Utilities> Show

Scheduled Jobs).
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l Click the Print icon drop-down menu and select Print Preview to preview the

report before printing.

l Click the Print icon drop-down menu and select Excel to export the report data

to an Excel spreadsheet as unformatted data.

l Click the Print icon drop-down menu and select Excel (Formatted) to export

the report data to an Excel spreadsheet that includes much of the Spring-

brook formatting found on the printed version of the report.

l Once the report is generated, you can also display the report using the View

Reports window (SS> Utilities> View Report).
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CM> Utilities> Setup

Set up the CMModule

Summary

The Setup window is used to define which modules the Contact Management module will

interface with and define other contact management module options.

Step by Step

1     Open the CM Setup window (CM> Utilities> Setup).

2     Complete the Interfaces section. 

l The Interfaces section is where you set up which modules will interface with the

Contact Management module.

l Check the Accounts Receivable toggle to create Accounts Receivable

invoices from issue steps. Invoices will be created in AR> Invoices> Gen-

erate.

l Check the Utility Billing toggle to create service requests from issue steps.

Service requests will be created in UB> Service Requests> Input.
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l Check theWork Orders toggle to create work orders from issue steps. Work

orders will be created in WO> Work Orders> Work Orders.

l Actions taken on issue items are set up with the issue type in CM> Main-

tenance> Issue Type> Steps tab> Action section.

3     Complete the Settings section. 

l Specify a Starting Invoice Batch Number.

l Issue steps can be used to create Accounts Receivable invoices in the AR

module. The Starting Invoice Batch Number field is used to define the batch

number you want to use when creating Accounts Receivable invoices in the

AR module. This is the first batch number that will be created in AR> Invoices

by the Contact Management module in every new fiscal period. As you close

batches in AR> Invoices created by issues, the Contact Management module

will increment the batch numbers that are created. You can generate and com-

mit up to 100 AR Invoice batches in a fiscal period from the Contact Man-

agement module.

l Only batch numbers in increments of hundreds can be entered in this

field.

l Check the Use Citation Number in Invoices Description toggle to display the cita-

tion number of the issue that generates the AR invoice in the description field of the

invoice. The invoice description field will display the text “Citation Number” followed

by the value entered in the Citation Number field in CM> Issues> Issue Step

Search> General tab> Issue section. If the Citation Number field is blank, the issue
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type description will print in the AR Invoice description field.

l If you do not check this toggle, the issue type description will display on the

AR Invoice. You can view the description field of an AR invoice in AR>

Invoices> Enter Invoices> Description field.

l An issues type description is set up in CM> Maintenance> Issue Type>

General tab> Type section> Description field. This field will also print on

the AR invoice.

l If you have changed the field label of the citation field in CM> Utilities>

Setup CM, the contents of that field will still display on the AR invoice,

but the text “Citation Number” will still display on the AR invoice.

l Check the Enforce Unique Citation Numbers toggle to force all citation numbers

to be unique. If you change the field label of the Citation Number field you can still

use this toggle.

l Checking this toggle will also force you to enter a citation number when you

are creating new issues.

l Check the Enable Queue Restrictions toggle to enable the following functionality.

Note that this functionality applies only to actual Issues, and not the maintenance of

Issue Types.

l If you are a Queue Member, you may change anything, including the user, on

a step.

l User list will display all users for the current queue.

l Queue list will display all queues for which you are an administrator.

l If you are not a queue administrator, then queue is disabled.
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l If you are not a member of the current step's queue, you will not be able to

modify anything on that step.

l Click the Save icon when the setup is complete.

4     Track any changes made to the CM Setup window. 

l Click the Audit Trail icon to open the Audit Trail window.

l Use the Search Criteria section to sort the displayed audit trail.

l The Audit Trail History section will provide details about any changes made to the

setup window including the date of the change, type of change made, user that

made the change, and data table that was edited.
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CM> Web Approvals

Approve Web Submissions

Summary

The Web Approvals batch process is used to approve or reject issues submitted through

the Online Code and Contact Management application. This process will only be enabled if

the Require web approvals toggle is checked on the Online Code and Contact Man-

agement Setup window (SS> Web Application Setup> Online Code and Contact Man-

agement> General tab).

Step by Step

1     Create a Web Approvals batch. 

l Select the Web Approvals palette in CM> Web Approvals. This will expand the Web

Approvals palette and display the steps of the batch process.

l Modify an existing batch or create a new Web Approvals batch.

l Select a batch number from the drop-down menu at the top of the Web

Approvals palette to select an existing batch.
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l Select New from the Web Approvals batch number drop-down menu to create

a new batch. This will open the New Batch window.

l The Batch Month and Batch Year of the Web Approvals batch is used

for reference only and is not necessarily the fiscal month and year the

transactions in the batch will be posted to.

l Click the Generate icon to populate the Batch Number field with the

next available batch number. Batch numbers are limited to five digits

and must be unique within the batch month of the batch year.

l You can also manually create a new batch by entering a Batch Number

and clicking the Save icon .

2     Generate the web approvals. 

l Open the Generate window (CM> Web Approvals> Generate).

l The Issue Type field is used to filter the types of issues that will be included in the

approvals batch.

l Use the Select All and Select None icon drop-down menus to quickly

specify the issue types you would like to include.

l Issue types are created and maintained on the Issue Type Maintenance win-

dow (CM> Maintenance> Issue Type).
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l The Issue Entry Date From and Issue Entry Date To fields are used to filter the

issues included in the approvals batch by the date that the issues were initially sub-

mitted. These are optional fields.

l The Resolution Type field is used to set a default Resolution Type to be applied to

all issues included in the batch. The default Resolution Type can be overridden on

the Edit step. This is an optional field.

l Resolution types are created and maintained on the Resolution Type Main-

tenance window (CM> Maintenance> Resolution Type).

l The Resolution Notes field is used to record any additional notes regarding the res-

olution. This is an optional field.

l These notes will appear on all of the issues in the batch as entered. If you

would like to add unique resolution notes to each issue included in the batch,

you will have the opportunity to do so on the Edit step.

l This field is limited to 500 alphanumeric characters.

l Check the Send notification to Issue creator toggle to automatically set each

issue included in the batch to notify the issue creator. This setting can be changed

on individual issues in the Edit step.

l You can also click the Create icon to add an individual web approval to the

batch. This will launch the Web Approval Selection window.

l Enter the desired filter details in the Search Criteria section and click the

Refresh icon to display the web submissions that meet the criteria.

l Select the desired web submissions and click the Confirm icon to add the

selected submissions to the batch. Use the SHIFT or CTRL keys to select mul-

tiple submissions.
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l The selected web submissions should now be displayed. Only the displayed

submissions will be included in the batch. The filter criteria entered elsewhere

on this window will be disregarded if individual web submissions are added to

the batch.

l Click the Confirm icon to generate the Web Approvals batch.

3     Review the included web issues. 

l Open the Edit window (CM> Web Approvals> Edit).

l The Edit window will display all of the web approvals that meet the filter criteria set

in the Generate step.

l Highlight an issue in the data grid and the details associated with that issue will pop-

ulate the Maintenance section below.

l The Issue Type, Issue Date and Description fields will populate with the

issue details specified by the individual that submitted the issue. These fields

can be edited.

l Check the Reject toggle if the issue should be rejected.

l Rejected issue submissions will be saved as read-only records in the

Web Approval Maintenance window but will not be converted into active

CM issues.

l Enter a Lot or click the field label to select one from a list.

l You are not required to attach a lot to the issue. Active issues attached

to lots will display in the Contact Management field of the Lot
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Maintenance window (SS> Maintenance> Lot).

l The Resolution Type and Resolution Notes fields will populate with the

details specified on the Generate step. These fields can be edited if desired.

l Check the Notify toggle if you would like to notify the issue creator when their

submitted issue has been processed.

l Click the Save icon to proceed.

4     Commit the Web Approval batch. 

l Open the Commit window (CM> Web Approvals> Commit).

l Click the OK button to commit the approvals batch.

l Approved issues will now be available on the Issue Maintenance window (CM>

Issues> Issue Search).
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